System Upgrades to Version 3.6

We still offer upgrade service for older Lenz Systems, Version 3.0 and later, to Version 3.6